问题描述:
MQ检测提示线下协议出现超时,在服务员点单上商品信息/包厢动态能正常同步。用服务员点单APP进行点单,未挂会员的包厢可进行正常点单,但是已挂会员信息的包厢点单时出现报错。
排查思路:
首先进行常规的协议超时问题排查,详见:MQ检测提示线下协议出现超时 | K米服务中心 (ktvme.com)。确认不是由该原因引起后,查看日志。查看日志可以看到日志在不断重复的下发会员售卡信息。
问题原因:
线上队列下发,数据库进行处理后返回。数据库的执行时间为6s,线上执行时间判定6s为超时后重复下发队列信息导致线上消息通道被堵塞。
解决办法:
由研发解决,将超时时间修改为10s。该方案为临时方案,无法保证后续如果数据库执行时间变长而出现同样的问题。
后续需要对数据库进行优化处理。